How to find error logs of analisys for maven based project?


I'm trying to figure out why Upsource cannot find some class imports in multimodule maven based project. E.g.  it could not resolve "import" in module1 but could resolve the same import in module2.

Recently I got this:

"Maven model conversion finished with errors. See .idea/maven/mvn.out in the revision file tree using the Upsource UI"

I tried to find "mvn.out" like described in this topic but I cannot find even ".idea" folder.

Can anybody help me to figure out why my project cannot be successfully analyzed by Upsource? The same project successfully compiled by IDEA with the same maven settings.

I'm using Upsource Build 3.5.3597

Comment actions Permalink

Hi Dmitry,

If a model convertion had a place, there should be .idea folder in Upsource's "browse code" view (probably in a different revision).

Could you please try the following approach?

If it still doesn't help, please shoot Upsource log to upsource-support at

Comment actions Permalink

Thanks for help Artem!

When I follow instruction described in and download generated tree via url <Your_Upsource_URL>/~generatedTree/<Project_ID>:<Revision_ID> I was able to find mvn.out. However I still cannot find .idea folder in upsource code browser....

Regarding the problem with "import" I think I resolved it via adding http.proxy/https.proxy VM variables in upsource distribution VM parameters. But I also have a proxy definition in maven settings like this:


And I guess that this is not enough in this case. During investigation of some logs in mvn.out I found that you are using Eclipse Aether for resolve maven devepnencies. In this case I guess that specifying proxy only in maven settings isn't enough since this library uses system proxy settings for dependencies resolving. So I think you can manually parse settings.xml and find <proxy> definition tag and then propogate this proxy definition to Aether resolver directly. 


Please sign in to leave a comment.