upsource cannot start port already used

I put Hub, teamcity, youtrack and upsource on same computer, all are behind my apache proxy that forward request on port 80 to each service based on url base to 127.0.0.1:portOfService (teamcity.mycomputer.com, etc).

Sometimes it happens that the port 8082 is already used when trying to launch upsource with "D:\mycomputer\upsource-3.5.3616\bin\upsource.bat start > D:\mycomputer\start_upsource.log"

Errors usually happens on restart of computer, like if I tried to access upsource but it was not started yet, then I go on server, try to start but port is used. It also happened after a good/failed stop of upsource if I do not mistaken.

With TcpView I cannot force close connection of that "non-existent" listening socket.

I manage to fix that by restarting computer and start upsource straight

 

Not related question:

On restart, hub service base url is always back to http://myComputerName:8080/hub but every time I set it back in service with http://myTestUrl.com/hub, I installed hub with http://myComputerName:8080/hub but then how to force on restart to listen on 8080 with base url "http://myTestUrl.com/hub"?

3 comments
Comment actions Permalink

Hi Yoann,

You might want to reconfigure Hub base URL via a command line. Try the following approach:

<Hub_instal_dir>/bin/hub.bat configure --base-url=http://myTestUrl.com/hub --listen-port=8080

0
Comment actions Permalink

Hi,

Thank you, it says "Failed to create config directory: C:\ProgramData\JetBrains\Hub\conf".

I installed hub via MSI exe, on my second HDD on D:\, I looked on documentation but could not find the option to tell it to try to do that on disk D:

I even executed the command from within the folder "D:\Jetbrains\Hub\bin".

Would it be a problem if I create the folder "C:\ProgramData\JetBrains\Hub\conf" manually in C: ? Conf would be on C but everything on D:

0
Comment actions Permalink

Hello, Yoann!

Could you please try to run that command 
<Hub_instal_dir>/bin/hub.bat configure --base-url=http://myTestUrl.com/hub --listen-port=8080

from elevated CMD (run as administrator).

If it keep failing with error, could you please open directory "C:\ProgramData\JetBrains\Hub\conf" manually (this directory is not visible to users by default and require elevation to administrator) and find file 
internal/bundle.properties file there, the following two properties should have been already set: base-url and listen-port.

You might manually change those properties to the following values:

base-url=http\://myTestUrl.com/hub
listen-port=8080

0

Please sign in to leave a comment.