Upsource Cassandra database errors problem

After problems with space and no connection to upsorce site log file attached, we are expand diskspace and reboot upsorce cassandra, when reindexing database it cause 

  • mixed comments from current and different repositories
  • comments sometimes disappears
  • files from other commits and repositories shows randomly

Any clue to deal wit this?

ERROR LOG:

http://gofile.me/6tGIo/LEOmVjdOG  - now is working link ;)

23 comments
Comment actions Permalink

Hello,

Looks like Upsource DB got in the incorrect state after disk space issue.

Try to take a backup and restore Upsoure on it - https://www.jetbrains.com/help/upsource/3.5/backing-up-and-restoring-data.html

0
Comment actions Permalink

If you make a backup and then restore, does I will not do exactly the same and will restore a backup that is mixed. Or after Restore tool re-index?

0
Comment actions Permalink

After a restore, all repo content will be fetched/indexed from scratch. 

0
Comment actions Permalink

@Artem Rokhin 

 

After a restore, all repo content are fetched/indexed from scratch. It seems that everything is all right

 

Thanks,

0
Comment actions Permalink

Now my guys complain that comments are gone? Is possible that Upsorce has not finish reindex of all data?

0
Comment actions Permalink

Probably review data was missed during restoring from backup. Let's do the following:

1. Navigate to the backup folder you used for the restore and copy this directory: <your_backup>/data/.backup

2. Stop Upsource

3. Put .backup directory to the <Upsource_home_dir>/data folder

4. Start Upsource

0
Comment actions Permalink

I still do not see comments

 

I try with new updated system 3.5 but still no comments

0
Comment actions Permalink

What if you open one of the files in this directory <your_backup>/data/.backup/review, do you see any review data there?

0
Comment actions Permalink

Jes I see review but no comments of this reviews!

 

0
Comment actions Permalink

What if you try to launch your previous Upsource instance and try to take a backup one more time?

0
Comment actions Permalink

I'm going to try to put the first base before the whole process of restore

thanks for your help

0
Comment actions Permalink

When I put back orginal data file all OK. From the backup does not withdraw comments of review.

0
Comment actions Permalink

Ok, got it. Could you please try to take a backup from the Upsource instance which shows comments and reviews and right after that send me Upsource logs?

0
Comment actions Permalink

What log that you need? Upsorce/logs/Cassandra ?

0
Comment actions Permalink

Upsource/logs/upsource-frontend

0
Comment actions Permalink

all logs from this folder?

0
Comment actions Permalink

I see the issue.. It's already fixed in the master and will be included in the nearest release in several weeks. Unfortunately, DB is in the incorrect state and Upsource cannot dump your reviews. If you don't have historical backups, use a backup which you have, but in that case review data will be lost. 

To avoid such failures in the future, please configure automatic backup. 

0
Comment actions Permalink

We doesn't have backup! This DB is only that work with reviews comments.

I didn't understand what we can now do to properly backup this DB.

Thanks,

0
Comment actions Permalink

A backup cannot be successfully completed on this DB, because DB is corrupted. Sorry..

 

 

0
Comment actions Permalink

What is our option to fix that?

0
Comment actions Permalink

No options( Just start a new instance.

0

Please sign in to leave a comment.