upsource update from 3.5 to 2017

Hi all !

is there any possibility to update from version 3.5.3616 to version 2017.1.1781 ? when i tried to update via instruction i got the error message:

"The database in the /opt/upsource.old/data is from version 3.5.3616. You cannot upgrade to version 2017.1.1781 from this source. To continue with this upgrade, change the upgrade source and select a backup copy of your existing installation. "

what i do wrong ?

2 comments
Comment actions Permalink

Yes, sure. First, take a backup from version 3.5 and then use it setup Upsource 2017.1

Please carefully read this instruction - https://www.jetbrains.com/help/upsource/2017.1/upgrade-with-a-zip-distribution.html?search=upgrade

0
Comment actions Permalink

tnx for answer !

i do my update step by step as in instruction: first of all i backed up my current  3.5.3616 version, then unpacked a zip archive and started upsource.sh script, opened update page in browser, clicked to "update" button, then in "source" field i selected my 3.5.3616 backup folder and got an error: "The database in the /opt/upsource.old/data is from version 3.5.3616. You cannot upgrade to version 2017.1.1781 from this source. To continue with this upgrade, change the upgrade source and select a backup copy of your existing installation. "

0

Please sign in to leave a comment.