Upsource IntelliJ Plugin-> javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

Hi, 

I am having problems connecting intellij upsource plugin with our upsource server. 

From web browser everything works as expected. 

From intellij (when I've enabled debug for upsource) I get:

com.jetbrains.upsource.idea.client.HttpSupportProvider$MyException: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure
at com.jetbrains.upsource.idea.authorization.ProxySettingsAwareHttpSupportProvider.doPerformHttpRequest(ProxySettingsAwareHttpSupportProvider.java:97)
at com.jetbrains.upsource.idea.authorization.ProxySettingsAwareHttpSupportProvider.performGetRequest(ProxySettingsAwareHttpSupportProvider.java:37)
at com.jetbrains.upsource.idea.client.UpsourceClientsManager.getJsonResponse(UpsourceClientsManager.java:519)
at com.jetbrains.upsource.idea.client.UpsourceClientsManager.computeUpsourceClientVersion(UpsourceClientsManager.java:491)
at com.jetbrains.upsource.idea.client.UpsourceClientsManager.getClientFactory(UpsourceClientsManager.java:237)
at com.jetbrains.upsource.idea.client.UpsourceClientsManager.access$200(UpsourceClientsManager.java:51)
at com.jetbrains.upsource.idea.client.UpsourceClientsManager$1.run(UpsourceClientsManager.java:132)
at com.jetbrains.upsource.idea.util.Util.lambda$runUnderProgress$3(Util.java:329)
at com.intellij.openapi.progress.impl.CoreProgressManager$3.run(CoreProgressManager.java:267)
at com.intellij.openapi.progress.impl.CoreProgressManager$TaskRunnable.run(CoreProgressManager.java:726)
at com.intellij.openapi.progress.impl.CoreProgressManager$6.run(CoreProgressManager.java:410)
at com.intellij.openapi.progress.impl.CoreProgressManager.a(CoreProgressManager.java:176)
at com.intellij.openapi.progress.impl.CoreProgressManager.a(CoreProgressManager.java:556)
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(CoreProgressManager.java:501)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:66)
at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(CoreProgressManager.java:163)
at com.intellij.openapi.application.impl.ApplicationImpl.a(ApplicationImpl.java:594)
at com.intellij.openapi.application.impl.ApplicationImpl$2.run(ApplicationImpl.java:334)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
Caused by: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

 

I've added manually cert (downloaded from browser) to ...idea/jre64/lib/security/cacerts

when I list the certs I can see the cert for my server

keytool  -list -keystore ...idea/jre64/lib/security/cacerts

 

My machine is linux.

 

Thank you for you answer

9 comments

What if you disable SSL validation here:

 

0

Hi, 

 

I've tried triggering that on/off  no success. I've also checked "Accept non-trusted certificates automatically" 

0

Any update on this ? 

The only reason we are looking into upsource is the IDE integration. It would be really good if I can get some help with this. 

0

What proxy server are you using? Is there any non-default configuration?

0

we are using cloudflare which does ssl termination and forwards http to nginx which listen on port 80 and forward config to upsource server.

There is nothing special about the configuration. I can send you the address of the server in PM so you can try.

 

I've just realized that you don't have PM messages. I can send you the link in email or chat, etc. but would not feel comfortable to leave it here in the public forum 

0

Please send it to artem.rokhin at jetbrains.com

0

Ok, I clicked on test connection button and was redirected to your Upsource instance for the authentication.

And what happens to you when you test connection?

0

This is strange, I got your message and tried myself again, and I got connected to the authentication page BUT 

 I've noticed that I am not in the main project  so I've switched back to the main. I've tried to connect and got an error again. (red pop-up)  

So I've played a bit and the way I got it to work in the main project was -> 1.removed the remembered url and saved with ok (which closes the dialog). 2. closed the intellij. Open the intellij again went to upsource connection and this time it was working. 

 

Yesterday our admin was playing a bit with the network so he must have done something which is good, but intellij has remembered bad connection somehow so I was not able to verify the success. But it seems that it works now (with this strange bug). 

I will ask him what he has done and will let you know. 

Thank you 

 

0

Please sign in to leave a comment.