Upsource IIS 8 reverse proxy does not work

I followed the explanation here: https://www.jetbrains.com/help/upsource/proxy-configuration.html to configure an IIS Reverse Proxy for upsource (to get SSL). But when navigating to the URL the page only loads partially and tries to reconnect. It seems to be related to a missing websocket connection. The website works fine when directly accessing it via localhost:8082. The login via the external hub seems to work, at least the profile picture is loaded.

System:

Windows Server 2012

IIS 8.0.9200.16384

Upsource 2017.2.2197

External Hub: 2017.3.6757

8 comments

I have the same problem, according to documentation this should help:

`upsource.bat start --J-bundle.websocket.compression.enabled=false`

but it does not, it tells that option is unknown :(

 

 

0

Same here, problem still exists. This line was just recently added, maybe we have to wait for a new version for this command to work?

0

Use this one http://download.jetbrains.com/upsource/upsource-2017.2.2223.zip

Command should be `upsource.bat start --J-Dbundle.websocket.compression.enabled=false`

0

I am running into the same issue.

I started the service with the compression enabled=false and still getting where the partial page load and continuously trying to reconnect.

My base URL is http://code-review-us.  This is an internal CNAME to our network.

 

0

Hello, i'm also getting the same issue
using
Reverse proxy with SSL
Upsource 2017.03.2888  (http://localhost:8083)
win 2012r2
IIS 8.5.9600

Command Dbundle.websocket.compression.enabled=false is not working for me.

Still getting connecting issue when we open the upsource
Does somebody have a fix for this issue ?



0

For everyone who Dbundle.websocket.compression.enabled=false doesn't work just install WebSocket feature in IIS.

Works on Windows Server 2016

0

Note: on IIS 8.5 set HTTP1.1 at ARR PROXY-Settings. Otherwise the websocket connects, but there's no communication.

upsource v. upsource-2018.2.1291

https://www.jetbrains.com/help/upsource/proxy-configuration.html#IISreverseProxy

0

Please sign in to leave a comment.