Upsource docker reverse proxy not working.

Hi, I just installed upsource in a docker-compose infrastructure. Upsource was installed accordingly to the documentation site and was ok, but when is accessed via reverse proxy, I get a 404 not found from Jetty. 

I have to mention the docker infrastructure runs on a centOS node in AWS. 

Upsource has been correctly configured on docker, because I used the same configuration on AWS on localhost and it worked fine, (base-url changed with localhost :) )

-----Configuration from reverse proxy --------

# Configuration for code review
location /upsource/ {
# to proxy WebSockets in nginx
    proxy_pass http://upsource:8989/;
    include /etc/nginx/conf.d/upsource_params;
}

docker run -d --name upsource --net infrastructure_default \
-v /home/centos/upsource/data:/opt/upsource/data \
-v /home/centos/upsource/conf:/opt/upsource/conf \
-v /home/centos/upsource/logs:/opt/upsource/logs \
-v /home/centos/upsource/backup:/opt/upsource/backups \
-p 8989:8989 \
jetbrains/upsource:2017.2.2307 \
configure --listen-port 8989 --base-url https://aws-node/upsource/

I don't see any errors in logs. Also checked jetty's logs, and it looks like it was correctly initialized. AWS Node is a t2.xlarge, so it has 16 GB RAM 

1 comment

[update] Fixed.

It seems nginx didn't liked "include upsource_params ". I had to put the configuration for reverse proxy in clear and it worked just fine.

0

Please sign in to leave a comment.