[Solved] Index not found for projects.reviews

I installed Upsource on our server and configured it. I was able to successfully add my project.

When I attempt to view a commit or comments, I see:

"Internal error: Invalid index expression, index reviews_idx not found for projects.reviews"

I believe this error is causing lots of miscellaneous links to fail within Upsource. I am unsure how to proceed.


Hey Andrew,

As you see some indexes got corrupted. There are 2 approaches to resolve the issue: restore instance from backup; initiate index rebuild on the Cassandra level. The easiest way is to restore the instance via a backup.


Could you explain or link to how to initiate the index rebuild on the Cassandra level? I'm going to attempt to do a restore, but I'm concerned they may be corrupted in the only backup I have. It's a completely new system and no data needs to be preserved yet.


Scratch that. It's solved and I wanted to update for future readers:

I was able to restore from a backup and it seemed to work.

Unsure if it was related, but I also ran this https://www.jetbrains.com/help/upsource/outofmemory-exception.html because of https://www.jetbrains.com/help/upsource/common-issues-with-upsource.html.


Please sign in to leave a comment.