Failed to import commits graph error


I tried to create new project on clean latest upsource installation (Build 3.0.4421) but got following errors:

12:12:58: Check for VCS changes completed with errors. jetbrains.vcs.server.api.VcsServiceException: Failed to construct commits graph for test{mappings: 1, mounts: 0}. Failed to construct graph for test:test. Failed to collect commits graph for test:test. jetbrains.buildServer.vcs.VcsException: Fail to update 'refs/heads/Performance' (LOCK_FAILURE).
12:12:58: Project test init failed due to unrecoverable VCS problem: Failed to import commits graph
2016-09-16 12:12:58,906] ERROR lyzer:INIT_CLUSTER-4 test ti.init.InitCommitsGraphDriver - Project test init failed due to unrecoverable VCS problem: Failed to import commits graph
om.jetbrains.upsource.UpsourceException: Failed to import commits graph
at com.jetbrains.upsource.backend.cli.multi.init.InitCommitsGraphDriver.analyze(
at com.jetbrains.upsource.backend.cli.stages.driver.InitGlobalDriverWrapper.analyze(
at com.jetbrains.upsource.backend.cli.multi.init.InitPipeline.lambda$getTasks$61(
at com.jetbrains.upsource.backend.cli.multi.tasks.MultiProjectTaskFactory$TaskExecutor$
at __.project_test.__(
at org.jonnyzzz.stack.NamedStackFrame.frame(
at com.jetbrains.upsource.backend.cli.multi.tasks.MultiProjectTaskFactory$TaskExecutor.executeTask(
at com.jetbrains.upsource.backend.cli.multi.tasks.MultiProjectTaskFactory$TaskExecutor$
at com.jetbrains.upsource.backend.cli.multi.executor.ProjectSyncExecutor$ProjectTasks$1$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
at com.jetbrains.upsource.util.NamedDaemonThreadFactory.lambda$wrapRunnable$10(
how to resolve this issue?
Comment actions Permalink

Hi Andrey,

Looks like you have duplicated branches in your repo. For example with the same name but with difference in register.

Could you please post git ls-remote output to confirm this theory?

Comment actions Permalink

Thank you, duplicate branch was the root cause of the issue, issue solved.

Comment actions Permalink

Why upsource has a limitation for the similar tag names (e.g. case insensitive mode of operation over the names)? Is it a bug to be resolved in feature?
Suffer the same problem having similar tags in repo (capotal/non-capital letters in the tags).


Please sign in to leave a comment.