JavaScript ES6

I'm using Upsource 3.0 and JavaScript in my project. The JavaScript ES6 syntax always indicates that "Import declarations are not supported by current JavaScript version" likewise error message.

I couldn't find any useful document related in Upsource document so is there anyway to let Upsource recognize my ES6 syntax?

2 comments
Comment actions Permalink

Excellent question, I am wondering the same myself.

Similarly, how do you handle stuff like Angular JS directives in HTML? It creates a bunch of warnings while in PyCharm I can simply "add to custom HTML attributes"

0

Please sign in to leave a comment.