LDAP gives error code 32


I'm trying to configure the LDAP module, but I can't seem to get it to work. This is for version 2.5.

From the command line to test LDAP, this does work and returns my record:
ldapsearch -H ldap:// -x -b dc=eng,dc=efjdfw,dc=local '(uid=kbrannen)'

However, when I test in the LDAP module, it always fails and the hub/logs/jetpass-ldap.log shows me:

16 Dec 2015 16:08:17,330 INFO  [pPasswordAuthenticationHandler] kbrannen: auth in LDAP
16 Dec 2015 16:08:17,330 INFO  [LdapClient                    ] Constructed DN: kbrannen
16 Dec 2015 16:08:17,333 INFO  [pPasswordAuthenticationHandler] LDAP can't bind [kbrannen] [LDAP: error code 32 - No Such Object]

I have the module's values set as:

server url: ldap://,dc=efjdfw,dc=local
dn transform:
filter: uid=%u
select ssl key: no key
name: uid         (the real answer is "cn", i'm just using uid to simplify things)
login: uid
email: mail
vcs user name:  uid

I've tried "uid@efji.com" and "uid=%u" in the "dn transform" field and those didn't help either.

I'd appreciate any help you could give me in figuring out the right values because I can't seem to figure them out despite the fact that I can make ldapsearch work.


Comment actions Permalink

Sorry for the typo, I meant:  I've tried "%u@efji.com" and "uid=%u" in the "dn transform" field and those didn't help either.

That's as mentioned in other posts and neither of those work either.


Comment actions Permalink

Hi Kevin,

Have you tried "uid=%u,dc=eng,dc=efjdfw,dc=local" in the dn transform field?

Also what type of LDAP network do you have? Is it OpenLDAP?

Thank you.

Comment actions Permalink


Yes, I tried that DN after I'd posted and it doesn't help either. I've found out I'm hitting an openldap server.

A little more info after more investigation... I found a page that says the hub has a minimum requirement of java 1.7, while upsource has a minimum of 1.6. We have only 1.6 on the upsource server. Could that be our problem? (I'm thinking of spinning up a new VM and installing java 1.8, installing upsource there, then trying again, but I'm trying to avoid that work if I can. :))


Comment actions Permalink


Upsource 2.5 bundles java 1.8 within, so it shouldn't be the case here.

Comment actions Permalink

Hmm, OK, that's good to know I can cross the java version off the list. :)

I did find out that we have openldap v1.2.2, which is kinda old. Could that be an issue because the software is expecting something in the v2 series?

I got with our admin about the server and had him look at the logs. We can see error 32 there as well, but no other useful info. At this point, I'm stuck and it looks like we're going to have to give everyone a local account. :(



Please sign in to leave a comment.