Update from 2.0 to 2.5; Won't start

When upgrading from 2.0.3554 to 2.5 on an Ubuntu server, after copying conf and data from the backup and starting upsource, the service shuts down.
In logs/hub/logs/errors.log i find a JetPassRestException: "Can't add more then one license when Hub is hosted".

Any ideas?

16 comments
Comment actions Permalink

Øyvind,

Are you running standalone Hub instance?

Did you change Upsource URL when upgrading from 2.0 to 2.5?

Thank you.

0
Comment actions Permalink

No standalone instance. Just the embedded one. I have not altered the url either.

0
Comment actions Permalink

Ok, thanks for the clarification.

Could please attach logs folders from Upsource directory?  

0
Comment actions Permalink

Logs attached :)



Attachment(s):
upsourcelogs.zip
0
Comment actions Permalink

Just out of curiosity, do you really had several Upsource licenses in 2.0 installation?

Could you please check that?

0
Comment actions Permalink

How do I check it?

0
Comment actions Permalink

On the administration page there should be link to "licenses".

0
Comment actions Permalink

As far as I can see, we have only one licence.

License Name: Upsource 2.0 Free 10 Users Pack
Product: Upsource 2
License Type: Free
User Count: 10
Ban Guest: Allowed
Expiration Date: Unlimited
Free Updates Till: Mar 4, 2016

Audit events:
2015-07-13 15:39:52.916 Update LicenseSettings HUB Service Hub
0
Comment actions Permalink

Thank you.

It's really strange behaviour.. Could you please send us hub database from Upsource 2.0?

It's located here .\<upsource-2.0_home_directory>\data\hub

You might send it privately to upsource-support at jetbrains.com

Thanks in advance.

0
Comment actions Permalink

"Your request (1418) has been received and is being reviewed by our support staff."

0
Comment actions Permalink

Thanks, we got it.

I'll update you as soon as we have any results.

0
Comment actions Permalink

Well, your Hub DB indicates that Upsource service was duplicated.

Most likely it happened during upgrade to Upsource 2.5. Either you didn't copy conf folder from the backup OR merged conf folder from the backup with the existing conf folder in Upsource 2.5 directory.

How to fix it?

Unzip Uposurce 2.5 distributive from scratch, delete conf folder from there. Copy conf and data folders from the backup and paste it to the root of Upsource 2.5 directory. Try to run Upsource.

For sure we recognize absence of decent upgrade procedure in the current version Upsource and of course do plan to fix it in the nearest future. Please upvote corrsponding feature reqest-
https://youtrack.jetbrains.com/issue/UP-5366

0
Comment actions Permalink

I still get the same error, I'm afraid!

0
Comment actions Permalink

Ah, let's try the following workaround:

1) Make sure that Upsource is not running (./upsource.sh stop)
2) Run the following commands one by one:

./upsource.sh configure --disable.cassandra=true
./upsource.sh configure --disable.upsource-analyzer=true
./upsource.sh configure --disable.upsource-frontend=true
./upsource.sh configure --disable.upsource-monitoring=true

3) Start Upsource with

./upsource.sh start
(it will start Upsource with only one enabled service - Hub)
4) Navigate to http://your-upsource-url/hub/
services, there you will see 2 Upsource services.  Please delete one of them (the recent one)
5) Stop Upsource
6) Enable all services with opposite commands:


./upsource.sh configure --disable.cassandra=false
./upsource.sh configure --disable.upsource-analyzer=false
./upsource.sh configure --disable.upsource-frontend=false
./upsource.sh configure --disable.upsource-monitoring=false

7) Try to start Upsource

Just to clarify, steps above are about Upsource 2.5

Please let me know if it helps.
0
Comment actions Permalink

I got an error when I tried to delete (any of) the services.

0
Comment actions Permalink

What is the error?

Also could you please attach Upsource logs?

0

Please sign in to leave a comment.