Windows Firewall Settings for Upsource

We've recently installed Upsource to try it out with the free 10-user license. It's been installed on a domain-joined Windows 7 Pro machine.

I can run Upsource via the "upsource start" command and that works fine. We got it up and running (set to use port 8080), configured it with AD integration, and setup our first project. So far, so good, and we can access it from any other machine on the domain.

But of course, we want it to run as a Windows service, so I stopped it and used the "upsource service install /runAsSystem" command. This installed the service and I started it up via the Services MMC app. At this point I could access it on the machine running the service, but not from any other machine on the domain.

First, I thought that LocalSystem might not be the right account to run it under for making it available on the network, so I changed it to Network Service. That didn't work. Then I suspected the Windows firewall. Sure enough, I can turn off the firewall for the domain network and I can then access Upsource from other machines on the domain. So I turned it back on and added a firewall exception for the program that the service is configured to use: C:\Upsource\launcher\bin\JetService.exe, allowing access to all ports for TCP and UDP. But I still can't access Upsource from other machines on the domain.

Has anybody successfully configured Upsource to run as a service on a Windows machine and still be available through the Windows firewall?

Thanks!
Kevin Kuebler

2 comments
Comment actions Permalink

I resolved this for now by just opening port 8080 to anything on my domain. It might be good to be able to restrict this further to just the Upsource process if that's possible, but this works for now.

0
Comment actions Permalink

I added the 'java.exe' and 'javaw.exe' from 'internal/java/jre/bin' and now it works for me

0

Please sign in to leave a comment.