Error Starting UpSource 2.5

Hi

- I have a test installation with version 2.5 on a windows 7 machine
- I can ping the host name WIN-XY123 (no fully quallyfied but for testing only)
- when starting the service I get the error below in the log.

Any ideas?
Thanks
Arthur

[2015-11-18 21:44:15,890]  DEBUG - om.jetbrains.bundle.BundleMain - Failed to start JetBrains Upsource 2.5 due to unexpected exception: null
java.lang.NullPointerException
 at java.util.Hashtable.put(Hashtable.java:459)
 at java.util.Properties.setProperty(Properties.java:166)
 at com.jetbrains.bundle.BundledBuildTimePropertyProvider.addToServiceProperties(BundledBuildTimePropertyProvider.java:42)
 at com.jetbrains.bundle.ServicesConfiguration.getServiceConfiguration(ServicesConfiguration.java:175)
 at com.jetbrains.bundle.Services.getServiceStatusUrl(Services.java:439)
 at com.jetbrains.bundle.Services.<init>(Services.java:109)
 at com.jetbrains.bundle.Services.createServices(Services.java:155)
 at com.jetbrains.bundle.BundleMain.configure(BundleMain.java:157)
 at com.jetbrains.bundle.BundleMain.start(BundleMain.java:244)
 at com.jetbrains.bundle.BundleMain.start(BundleMain.java:208)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:497)
 at com.jetbrains.bundle.bootstrap.Bundle$EntryPointProvider$1.invoke(Bundle.java:108)
 at com.sun.proxy.$Proxy0.start(Unknown Source)
 at com.jetbrains.bundle.bootstrap.Bundle.start(Bundle.java:54)
 at com.jetbrains.launcher.AppProxy$4.call(AppProxy.java:83)
 at com.jetbrains.launcher.AppProxy$4.call(AppProxy.java:81)
 at java.util.concurrent.FutureTask.run(FutureTask.java:266)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
 at java.lang.Thread.run(Thread.java:745)

8 comments

Hi Arthur,

Could you please attach the entire contents from logs folder form Upsource home directory?

Thanks in advance.

0

Thank you.

It's an ugly bug that is not fixed yet - https://youtrack.jetbrains.com/issue/UP-4543

Please install Upsource to a folder without spaces in the name, e.g. C:\Upsource

Please let me know if it helps.

0

The problem persists. I attached the new log.



Attachment(s):
newlogs.zip
0

Well, could you please stop Upsource, uninstall Upsource service and try to start it via `upsource.bat start` command.

Please attach logs folders after that one more time.

Thanks for your patience.

0

That's what I initially did but it's always the same error. I tried with the service that it runs with System Account vs. Administrator when running from command line.

0

Arthur,

Could please clarify the full order of steps you have done? It seems that some of the Upsource services/processes weren't stopped correctly before the next run.

Also could you please do the following:

1. Stop Upsource
2. Uninstall Upsopurce service
3. Check that all Upsource related java processes are not running (might be done with process explorer https://technet.microsoft.com/en-us/sysinternals/bb896653.aspx)
4. Delete data and conf folders inside Upsource home directory
5. Start Upsource. Just with upsource.bat start

Please let me know about the results.

0

I got me a new VM and started by installing to C:\Upsource. Upsource starts now. So it looks like you said this was a problem with service and moving the installation folder.

Thanks!

0

Please sign in to leave a comment.