Upsource is terribly slow. What can I do about it?

Hi,

I just installed Upsource on a RHEL machine running on VMWare. It is terribly slow. Every page takes seconds to load. Even simple things, such as selecting a user out of a total three users, takes ages. In this state, we can't use Upsource. There is no recommendation on the machine size needed for upsource on the website. Does anyone have any experience with this? We have 2 CPU cores available on the machine, but the memory is rather limited at the moment. What's a good memory size for an Upsource machine, running nothing else than Upsource?

Best regards,
Bart

12 comments

Our admin increased the memory size to 6GB, which seems to help. It is now workable, but still not superfast. Would it be helpful to increase the number of CPU cores? We now have 2 cores.

0

Hi Bart,

Recommended minimum memory size is 8 Gbs and yes, increasing number of CPU cores would definitely help.

Upsource is pretty greedy for system resources, we are aware of it and continuously working on performance optimization that should be reflected in the coming releases.

0

Thanks, Artem. Perhaps you should consider putting some system requirements / recommendations on your website. I was looking for something like that, but I couldn't find it. I think it would certainly improve the "out of the box experience" to have the requirements right the first time.

0

Hy,
we have also performance issues.

In the browser, we are seeing always "reconnecting".
We are also on a Linux (Redhat) machine.

In the idea plugin we are always getting this exception:
com.github.nkzawa.socketio.client.SocketIOException: timeout


Thanks,
  Tom

0

Tom,

Do you have any kind of proxy server configured for Upsource instance? Or maybe you have a transparent proxy in your network?
If so, which one? Version?

Thanks in advance.

0

no, no proxy
Please find attache a printscreen of the chrome network debugger.

We are getting a lot of 502 error.

The pages are getting rendered correctly, but really slow.
upsource_slow.png

0

Hello,

That was a problem with upsource server. It's already fixed in current development branch and the fix is back-ported into 2.0.x branch, so, you'll get it with the next update (no ETA at the moment)

Regards, Denis

0

Hy,
my problem was related to a wrong ProxyPass configuration on our server.

I believed you meaned the browser proxy settings, thats we I previously saif 'no proxy'.


After I reconfigured the upsource server with no proxy, the speed is OK and also the IntelliJ-plugin is working:

./upsource.sh  configure --listen-port 8080 --base-url http://upsource.mydomain:8080


Thanks,
Tom

0

Hi Tom,

Thanks for the update. You said that ProxyPass was wrong, just out of curiosity, what Apache version are you using?

0

We have Apache 2.4.6 running under CentOS Linux release 7.1.1503 (Core)
I missed to include the proxy_wstunnel module in the apache config.

Now with the proxy_wstunnel, everything is running very fast.

I just appended this into the file /etc/httpd/conf.modules.d/00-proxy.conf

LoadModule proxy_wstunnel_module modules/mod_proxy_wstunnel.so


Thanks for all your help,
Tom

0

Please sign in to leave a comment.