Trouble Upgrading Upsource EAP from 2.0.2812 to 2.0.3055

Hello,
I've tried upgrading to the latest Upsource EAP 2.0.3055 from the previous 2.0.2812 build and after the upgrade procedure Upsource refuses to start with the following entries in the log:

[2015-05-06 10:45:10,986] ================================================================ (start)
[2015-05-06 10:45:53,837] [Upsource Error] log4j:WARN No appenders could be found for logger (com.jetbrains.hub.service.HubAfterStartCallbackWithoutXmlConfig).
[2015-05-06 10:45:53,837] [Upsource Error] log4j:WARN Please initialize the log4j system properly.
[2015-05-06 10:45:53,837] [Upsource Error] log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
[2015-05-06 10:45:55,522] [Upsource Error] [2015-05-06 10:45:55,501]  ERROR - es.impl.HubConfiguratorService - Could not update service in Hub because <id>.service.id and/or <id>.service.secret properties not set or incorrect in conf/internal/hub.properties file. Please provide correct values for these properties. It may require to create service by hand, change its password or make it verified. Problem: Service 'vcs-settings' not verified or have wrong secret in Hub (http://127.0.0.1:3040/hub). Attempt to update it failed: Bundle hub service does not exists in Hub (http://127.0.0.1:3040/hub). Attempt to create it failed: HTTP 401 Unauthorized
[2015-05-06 10:45:55,522] [Upsource Error] com.jetbrains.bundle.util.hub.UpdaterHubServiceException: Service 'vcs-settings' not verified or have wrong secret in Hub (http://127.0.0.1:3040/hub). Attempt to update it failed: Bundle hub service does not exists in Hub (http://127.0.0.1:3040/hub). Attempt to create it failed: HTTP 401 Unauthorized
[2015-05-06 10:45:55,522] [Upsource Error]  at com.jetbrains.bundle.util.hub.HubServiceUpdater.ensureCreatedAndVerified(HubServiceUpdater.java:197)
[2015-05-06 10:45:55,523] [Upsource Error]  at com.jetbrains.bundle.util.hub.HubServiceUpdater.update(HubServiceUpdater.java:140)
[2015-05-06 10:45:55,523] [Upsource Error]  at com.jetbrains.bundle.services.impl.HubConfiguratorService.doStart(HubConfiguratorService.java:51)
[2015-05-06 10:45:55,523] [Upsource Error]  at com.jetbrains.bundle.services.impl.ServiceBase.start(ServiceBase.java:55)
[2015-05-06 10:45:55,523] [Upsource Error]  at com.jetbrains.bundle.Services.startService(Services.java:490)
[2015-05-06 10:45:55,523] [Upsource Error]  at com.jetbrains.bundle.Services.startAllServices(Services.java:467)
[2015-05-06 10:45:55,524] [Upsource Error]  at com.jetbrains.bundle.Services.start(Services.java:445)
[2015-05-06 10:45:55,524] [Upsource Error]  at com.jetbrains.bundle.BundleMain.start(BundleMain.java:245)
[2015-05-06 10:45:55,524] [Upsource Error]  at com.jetbrains.bundle.BundleMain.start(BundleMain.java:212)
[2015-05-06 10:45:55,524] [Upsource Error]  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[2015-05-06 10:45:55,524] [Upsource Error]  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
[2015-05-06 10:45:55,524] [Upsource Error]  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
[2015-05-06 10:45:55,525] [Upsource Error]  at java.lang.reflect.Method.invoke(Method.java:497)
[2015-05-06 10:45:55,525] [Upsource Error]  at com.jetbrains.bundle.bootstrap.Bundle$EntryPointProvider$1.invoke(Bundle.java:108)
[2015-05-06 10:45:55,525] [Upsource Error]  at com.sun.proxy.$Proxy2.start(Unknown Source)
[2015-05-06 10:45:55,525] [Upsource Error]  at com.jetbrains.bundle.bootstrap.Bundle.start(Bundle.java:54)
[2015-05-06 10:45:55,525] [Upsource Error]  at com.jetbrains.launcher.AppProxy$4.call(AppProxy.java:83)
[2015-05-06 10:45:55,526] [Upsource Error]  at com.jetbrains.launcher.AppProxy$4.call(AppProxy.java:81)
[2015-05-06 10:45:55,529] [Upsource Error]  at java.util.concurrent.FutureTask.run(FutureTask.java:266)
[2015-05-06 10:45:55,529] [Upsource Error]  at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
[2015-05-06 10:45:55,529] [Upsource Error]  at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
[2015-05-06 10:45:55,529] [Upsource Error]  at java.lang.Thread.run(Thread.java:745)
[2015-05-06 10:45:55,529] [Upsource Error] Caused by: com.jetbrains.bundle.util.hub.UpdaterHubServiceException: Bundle hub service does not exists in Hub (http://127.0.0.1:3040/hub). Attempt to create it failed: HTTP 401 Unauthorized
[2015-05-06 10:45:55,530] [Upsource Error]  at com.jetbrains.bundle.util.hub.HubServiceUpdater.getBundleHubServiceClient(HubServiceUpdater.java:449)
[2015-05-06 10:45:55,530] [Upsource Error]  at com.jetbrains.bundle.util.hub.HubServiceUpdater.ensureCreatedAndVerified(HubServiceUpdater.java:193)
[2015-05-06 10:45:55,530] [Upsource Error]  ... 21 more
[2015-05-06 10:45:55,530] [Upsource Error] Caused by: javax.ws.rs.NotAuthorizedException: HTTP 401 Unauthorized
[2015-05-06 10:45:55,530] [Upsource Error]  at org.glassfish.jersey.client.JerseyInvocation.convertToException(JerseyInvocation.java:984)
[2015-05-06 10:45:55,531] [Upsource Error]  at org.glassfish.jersey.client.JerseyInvocation.translate(JerseyInvocation.java:799)
[2015-05-06 10:45:55,531] [Upsource Error]  at org.glassfish.jersey.client.JerseyInvocation.access$500(JerseyInvocation.java:91)
[2015-05-06 10:45:55,531] [Upsource Error]  at org.glassfish.jersey.client.JerseyInvocation$2.call(JerseyInvocation.java:687)
[2015-05-06 10:45:55,531] [Upsource Error]  at org.glassfish.jersey.internal.Errors.process(Errors.java:315)
[2015-05-06 10:45:55,531] [Upsource Error]  at org.glassfish.jersey.internal.Errors.process(Errors.java:297)
[2015-05-06 10:45:55,531] [Upsource Error]  at org.glassfish.jersey.internal.Errors.process(Errors.java:228)
[2015-05-06 10:45:55,532] [Upsource Error]  at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:444)
[2015-05-06 10:45:55,532] [Upsource Error]  at org.glassfish.jersey.client.JerseyInvocation.invoke(JerseyInvocation.java:683)
[2015-05-06 10:45:55,532] [Upsource Error]  at org.glassfish.jersey.client.JerseyInvocation$Builder.method(JerseyInvocation.java:439)
[2015-05-06 10:45:55,532] [Upsource Error]  at org.glassfish.jersey.client.JerseyInvocation$Builder.post(JerseyInvocation.java:340)
[2015-05-06 10:45:55,532] [Upsource Error]  at jetbrains.jetpass.client.accounts.ServiceClient.createService(ServiceClient.java:48)
[2015-05-06 10:45:55,533] [Upsource Error]  at com.jetbrains.bundle.util.hub.HubServiceUpdater.createEmptyVerifiedService(HubServiceUpdater.java:118)
[2015-05-06 10:45:55,533] [Upsource Error]  at com.jetbrains.bundle.util.hub.HubServiceUpdater.getBundleHubServiceClient(HubServiceUpdater.java:444)
[2015-05-06 10:45:55,533] [Upsource Error]  ... 22 more
[2015-05-06 10:46:04,044] [Upsource Error] log4j:WARN No appenders could be found for logger (jetbrains.vcs.server.settings.log.VcsSettingsLoggerSetup).
[2015-05-06 10:46:04,044] [Upsource Error] log4j:WARN Please initialize the log4j system properly.
[2015-05-06 10:46:04,044] [Upsource Error] log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
[2015-05-06 10:46:13,092] [Upsource Error] [2015-05-06 10:46:13,089]  ERROR -                 bundle.startup - Error while starting JetBrains Upsource 2.0: Not allowed exit code -1 from process: bin/upsource-analyzer start
[2015-05-06 10:46:22,368] [Upsource Error] [2015-05-06 10:46:22,364]   WARN - y.util.thread.QueuedThreadPool - qtp1431324626{STOPPING,8<=1<=200,i=1,q=5} Couldn't stop Thread[qtp1431324626-138,5,]
[2015-05-06 10:46:22,368] [Upsource Error] [2015-05-06 10:46:22,366]   WARN - y.util.thread.QueuedThreadPool - qtp1431324626{STOPPING,8<=2<=200,i=0,q=2} Couldn't stop Thread[qtp1431324626-143,5,]
[2015-05-06 10:46:22,368] [Upsource Error] [2015-05-06 10:46:22,366]   WARN - y.util.thread.QueuedThreadPool - qtp1431324626{STOPPING,8<=1<=200,i=0,q=2} Couldn't stop Thread[qtp1431324626-164,5,]
[2015-05-06 10:46:22,368] [Upsource Error] [2015-05-06 10:46:22,366]   WARN - y.util.thread.QueuedThreadPool - qtp1431324626{STOPPING,8<=2<=200,i=0,q=1} Couldn't stop Thread[qtp1431324626-165,5,]
[2015-05-06 10:46:22,368] [Upsource Error] [2015-05-06 10:46:22,367]   WARN - y.util.thread.QueuedThreadPool - qtp1431324626{STOPPING,8<=1<=200,i=0,q=1} Couldn't stop Thread[qtp1431324626-166,5,main]
[2015-05-06 10:46:27,516] [Upsource Error] [2015-05-06 10:46:27,511]   WARN - y.util.thread.QueuedThreadPool - qtp1485616498{STOPPING,8<=2<=200,i=2,q=4} Couldn't stop Thread[qtp1485616498-60,5,main]
[2015-05-06 10:46:27,516] [Upsource Error] [2015-05-06 10:46:27,511]   WARN - y.util.thread.QueuedThreadPool - qtp1485616498{STOPPING,8<=1<=200,i=1,q=3} Couldn't stop Thread[qtp1485616498-61,5,]
[2015-05-06 10:46:27,879] ================================================================ (finish)

I followed the following procedure:
- Made a backup on 2.0.2812 installation
- Unarchived 2.0.3055 distribution into an empty directory
- Copied data and conf to the 2.0.3055 EAP root folder
- Started the Upsource

Am I doing anything wrong? Is the upgrade process supposed to work between the EAPs?

Thanks,
Milan

4 comments
Comment actions Permalink

Hi Milan,

Did you have guest user banned on your 2.0.2812 installation?

Thanks in advance.

0
Comment actions Permalink

Hi Artem.
I checked the configuration and it is true that the guest account is banned. Should I unban the guest, upgrade the installation and then ban the guest again?

Thanks,
Milan

0
Comment actions Permalink

Yep.

We've recently found this bug and it should be fixed by 2.0 release.

Sorry for that inconvenience.

0
Comment actions Permalink

Great, it's working again! Thank you. I'm looking forward to the 2.0 release :)

0

Please sign in to leave a comment.