recognizing branches with svn

I'm just getting started with Upsource with our existing svn repository.

Our layout is


I'm not sure how to get Upsource to recognize my repo's layout so that branch1 and branch2 show up as branches.

I've tried creating one big project for the whole repo and i've also tried adding projects for projectA and projectB. in both cases the only thing that shows up is "default".


Hi Dan, I think I'm seeing the same thing as you. I thought it might be related to the fact that the docs say to link it to the trunk branch. Did you link yours to the root of your repository?


I've tried creating projects that specify each of these repository URLs:

  1. svn://myserver/myrepo
  2. svn://myserver/myrepo/projectA
  3. svn://myserver/myrepo/projectA/trunk

No luck with any of them recognizing branches for any of them.

I'm using c++ so I specified the build system as "None".

Thanks for the reply. Any other thoughts?


No other suggestions. I upgraded our EAP yesterday and believe I'm seeing the same problem which caused me to point it to \trunk. See "Still indexing after 16 hours"


argh. just found this in the Upsource issue tracker:

sounds like branches in svn aren't actually supported and someone suggests using git-svn to work around the problem.

seems like the svn support is not complete at all and the Upsource info page is not to be trusted.


Hi Dan,

We are currently working on SVN branches support, but so far no estimates yet.

Sorry for that inconvenience.  


Thanks for the response.

Do you have instructions on how to use git-svn with Upsource as suggested?



We are working on it right now and I believe it should be ready shortly. I will update you when it gets ready.



Here you can find recommended by GitHub article on how to mirror svn repository to git.


Note, that such configuration is a workaround in order to detect SVN branches within Upsource and not officially supported by JetBrains. However you can assign issues right in this article if any.


Quick note:

To specify local git repository in "Repository URL" field you can use the following path "file:/<path to git repository>"

E.g. If your repository is located on the disc C in, let say, GitRepository fodler, your Repository URL will be: file:/c:\GitRepository


Hi to everybody,
I temporarily solved this problem. I'm using the multi-repository setup. I added the interested for me branches in this configuration. And now I could be up to date with all changes in these repositories.
But I'm still looking forward for fix from developers.
Thank you for great, useful new product.


Hello Sergii,
I have same problem and tried to solve same like you. But it didn't work. Can you post settings.json for project? Do you have mapping project from settings.json in the projects list to the administrative interface of the Upsource?

Thanks in advance.


Hi, Sorry for long silent.
The settings.json is located Upsource\data\vcs-settings\<Project id>\

And inside it is look like:
  "mappings" : [ {
    "id" : "<Your ID for branch>",
    "username" : "<username>",
    "vcs" : "svn",
    "url" : "<path>/trunk",
    "password-hash" : "<password-hash>"
    "id" : "Your ID for branch",
    "username" : "<username>",
    "vcs" : "svn",
    "url" : "<path>/branches/<branch name>",
    "password-hash" : "<password-hash>"
  } ]

Have fun.


Hi Artem,

any progress on this issue? Would be really cool if you guys could get this to work!

Thanks already for this great tool!



Please sign in to leave a comment.