recognizing branches with svn

I'm just getting started with Upsource with our existing svn repository.

Our layout is

/projectA/trunk
/projectA/branches/branch1
/projectA/branches/branch2
/projectA/tags/tag1
/projectA/tags/tag2
/projectB/trunk
/projectB/branches/branch1
/projectB/branches/branch2
/projectB/tags/tag1
/projectB/tags/tag2


I'm not sure how to get Upsource to recognize my repo's layout so that branch1 and branch2 show up as branches.

I've tried creating one big project for the whole repo and i've also tried adding projects for projectA and projectB. in both cases the only thing that shows up is "default".

Thanks,
Dan
14 comments
Comment actions Permalink

Hi Dan, I think I'm seeing the same thing as you. I thought it might be related to the fact that the docs say to link it to the trunk branch. Did you link yours to the root of your repository?

0
Comment actions Permalink

I've tried creating projects that specify each of these repository URLs:

  1. svn://myserver/myrepo
  2. svn://myserver/myrepo/projectA
  3. svn://myserver/myrepo/projectA/trunk


No luck with any of them recognizing branches for any of them.

I'm using c++ so I specified the build system as "None".

Thanks for the reply. Any other thoughts?

0
Comment actions Permalink

No other suggestions. I upgraded our EAP yesterday and believe I'm seeing the same problem which caused me to point it to \trunk. See "Still indexing after 16 hours"

0
Comment actions Permalink

argh. just found this in the Upsource issue tracker: https://youtrack.jetbrains.com/issue/UP-1797

sounds like branches in svn aren't actually supported and someone suggests using git-svn to work around the problem.

seems like the svn support is not complete at all and the Upsource info page is not to be trusted.

0
Comment actions Permalink

Hi Dan,

We are currently working on SVN branches support, but so far no estimates yet.

Sorry for that inconvenience.  

0
Comment actions Permalink

Thanks for the response.

Do you have instructions on how to use git-svn with Upsource as suggested?

0
Comment actions Permalink

Dan,

We are working on it right now and I believe it should be ready shortly. I will update you when it gets ready.

0
Comment actions Permalink

Dan,

Here https://github.com/nirvdrum/svn2git you can find recommended by GitHub article on how to mirror svn repository to git.

 

Note, that such configuration is a workaround in order to detect SVN branches within Upsource and not officially supported by JetBrains. However you can assign issues right in this article if any.

0
Comment actions Permalink

Quick note:

To specify local git repository in "Repository URL" field you can use the following path "file:/<path to git repository>"

E.g. If your repository is located on the disc C in, let say, GitRepository fodler, your Repository URL will be: file:/c:\GitRepository

0
Comment actions Permalink

Hi to everybody,
I temporarily solved this problem. I'm using the multi-repository setup. I added the interested for me branches in this configuration. And now I could be up to date with all changes in these repositories.
But I'm still looking forward for fix from developers.
Thank you for great, useful new product.

0
Comment actions Permalink

Hello Sergii,
I have same problem and tried to solve same like you. But it didn't work. Can you post settings.json for project? Do you have mapping project from settings.json in the projects list to the administrative interface of the Upsource?

Thanks in advance.

0
Comment actions Permalink

Hi, Sorry for long silent.
The settings.json is located Upsource\data\vcs-settings\<Project id>\

And inside it is look like:
{
  "mappings" : [ {
    "id" : "<Your ID for branch>",
    "username" : "<username>",
    "vcs" : "svn",
    "url" : "<path>/trunk",
    "password-hash" : "<password-hash>"
  },{
    "id" : "Your ID for branch",
    "username" : "<username>",
    "vcs" : "svn",
    "url" : "<path>/branches/<branch name>",
    "password-hash" : "<password-hash>"
  } ]
}

Have fun.

0
Comment actions Permalink

Hi Artem,

any progress on this issue? Would be really cool if you guys could get this to work!

Thanks already for this great tool!

Ralph

0
Comment actions Permalink

Hi Ralph,

Not yet so far. You can track the progress here - https://youtrack.jetbrains.com/issue/UP-1797

0

Please sign in to leave a comment.