White space in Workspace map name, causing errors

I'm trying to set up a project using Perforce as the VCS and it can't connect to the VCS. When test the connection, it gives me this error:

 
Test VCS connection failed.
Failed to parse perforce client mapping line: //depot/main/System Test

But I noticed that it connects properly when the name of the directory doesn't contain a space. Is there some way I can map to a file if there's a space in the file location? Maybe an escape key?

 

7 comments
Comment actions Permalink

Hi Aidan,

Did you try to quote the path as described in the perforce doc https://www.perforce.com/perforce/r12.1/manuals/cmdref/o.views.html? 

 

Spaces in path and file names

If a path or file name in a workspace view, branch view, or label view contains spaces, make sure to quote the path:
//depot/dir1/... "//cws/dir one/..."
0
Comment actions Permalink

Yes I tried that as well, still the same error. 

0
Comment actions Permalink

Aidan,

Could you please post a screenshot of your "Workspace mapping" field as we as upload upload Upsource logs to our ftp site - ftp://ftp.intellij.net/.uploads

Thanks in advance.

0
Comment actions Permalink

Here's the field:

So far I've tried:

//depot/main/System Test

"//depot/main/System Test"

//depot/main/"System Test"

"////depot//main//System Test"

 

And still nothing.

0
Comment actions Permalink

Hi Aidan,

What about logs, have you uploaded it? What is the archive name?

0
Comment actions Permalink

I can't navigate to the .uploads folder. All I see at ftp://ftp.intellij.net/ is lost+found, pub and welcome.msg

0
Comment actions Permalink

Aidan,

Sorry for the delay.

Could you please send it to upsource-support@jetbrains.com ?

Thank you,

0

Please sign in to leave a comment.