Upgrade from 2.0 to 2.5 fails

I renamed Upsource directore to Upsource_old.
Then unpack 2.5 version.
Then copied data and conf directories to 2.5 and started upsource.sh

On "Upsource Cluster Initialize Service" step I've got this:

[Upsource Cluster Initialize Service Error] log4j:WARN No such property [maxBackupIndex] in org.apache.log4j.FileAppender.
[Upsource Cluster Initialize Service Error] log4j:WARN No such property [maxBackupIndex] in org.apache.log4j.FileAppender.
[Upsource Cluster Initialize Service Error] Core version mismatch. Database update not possible
Upsource Cluster Initialize Service failed to start


How to migrate to 2.5?

Thank you!
1 comment
Comment actions Permalink

Hi Kirill,

Thanks for reaching out.

Backup/restore should be done instead. Please refer to this article - http://upsource-support.jetbrains.com/hc/en-us/articles/205018542-How-to-upgrade-your-Upsource-installation-

Long story short - make a backup in Upsource 2.0, copy data and conf folders from backup directory, paste them to Upsource 2.5 folder.

Please let me know if it helps.

0

Please sign in to leave a comment.