OAuth 2.0 Error

I have set up auth modules for Hub, GitHub and Google. When trying to log in or change passwords, the login seems to work, but they are redirected to an error page stating "The authorization server does not support obtaining an authorization entity using this method". When the users type in the url to the server afterwards, they get access.
How may I have configured this wrong?

9 comments
Comment actions Permalink

Hi,

Are there any other messages/stack traces along with this error - "The authorization server does not support obtaining an authorization entity using this method"? Screenshot will be much appreciated.

Thanks in advance.

0
Comment actions Permalink

Not too much more information.
I get this "developer message": unsupported_response_type: The authorization server does not support obtaining an authorization entity using this method.



Attachment(s):
Skjermbilde_2.PNG
Skjermbilde_1.PNG
Skjermbilde_0.PNG
0
Comment actions Permalink

Thanks for the clarification.

Could you please also post logs folder from Upsource home directory?

Thanks.

0
Comment actions Permalink

Archive seems to be corrupted. Could you please archive mentioned folder one more time and post it?

Thanks in advance.

0
Comment actions Permalink

It works now, thanks.

Will update you shortly.

0
Comment actions Permalink

Hi,

It seems that we would also need a har file. How it can be saved:

  1. In Chrome, right-click on that page and select "Inspect Element". This will open the Developer Tools panel.

  2. In the Developer Tools panel at the bottom, select the Network tab.

  3. At the bottom, the Record button appears as a solid black circle. Select it and it will turn red to indicate recording has begun.

  4. Go to Upsource login page and reproduce the issue.

  5. Right-click anywhere in the Network area and select "Save as HAR with Content".



Thanks in advance.

0
Comment actions Permalink

I can no longer reproduce the issue. Strange!

0

Please sign in to leave a comment.