SVN/HTTPS over proxy?

Hi

I'm setting up Upsource for the first time, and need to access an SVN server via HTTPS over a proxy server. Normally, I have a tunnel open to the proxy server and I'm forwarding port 3128, then have configured in my ~/.subversion/servers
[global]
http-proxy-host = 127.0.0.1
http-proxy-port = 3128

This works from the command line where Upsource is running, but Upsource itself appears(?) to be using its own SVN library, and it can't access the SVN server. Is there a way to get this to work, or to force Upsource to use the command-line client?

In IntelliJ IDEA I have it configured to work with the command line client, and to use the local .subversion configuration, and this works.

Thanks!
Patrick

3 comments
Comment actions Permalink

Hi Patrick,

Thanks for getting in touch.

Actually it should work in that way. Upsource uses SVNkit client that should look at ~/.subversion/servers

Could you please restart Upsource, reproduce the issue (click to test connection button) and send us logs folder from Uspource home directory?

Thanks in advance.

0
Comment actions Permalink

Ok, it looks like it was a likely a networking problem on the VM where I installed it. I restarted the box, then upsource, and was able to connect to SVN. Sorry for the trouble - thanks for confirming that the proxy settings were indeed in the right place - gave me the incentive to try again.


Regards
Patrick

0
Comment actions Permalink

Ok ;)

Please let me know if you have any other questions regarding Upsource.

Thanks in advance.

0

Please sign in to leave a comment.