Subversion and file's encoding

It is possible to support file's in ANSI encoding? At this moment I can't see Russian characters in C++ files in code-review UI.

5 comments
Comment actions Permalink

Anton,

The following steps might help you to resolve the issue:

1. Open <Upsource_home_dir>/conf/Upsource-analyzer folder
2. Create a file upsource-analyzer.jvmoptions
3. Add there the following line +Dfile.encoding=UTF-8
4. Restart Upsource

Note that it will effect on new commits only.

Please let me know if it helps.

0
Comment actions Permalink

Unfortunately - not :( I still see � instead of Russian characters.

0
Comment actions Permalink

Hi Anton,

Could you please open raw of any file with problematic content through Upsource and let us know how it looks like?

How it can be done:

- On project main page, expand any revision
- Click on file with Russian characters and go to "view file"
- In top right corner click to "Raw" button.

Thanks in advance.

0
Comment actions Permalink

Anton,

Nevermind, there are some product modifications that should be done on Upsource side to support ANSI files with Russian characters, here is a corresponding request that you might want to upvote https://youtrack.jetbrains.com/issue/UP-2677

Till that implemented we would recommend to convert all problematic files to UTF-8 encoding  

0
Comment actions Permalink

The same story here. Invalid characters.

Previously we used Phabricator. In settings we pointed to cp1251 as encoding for Subversion. And we had no any problems...
Unfortunately it's impossible to convert all files to UTF-8 at this moment.

Anton

0

Please sign in to leave a comment.