Indexing takes abnormally longer time, seems not indexing any more on the projects have many revisions

We have added around 10 Subversion projects (Most of them have more than 1000 commits in each project). It seems taking much time (2-3 days still show as indexing inprogress) than usual. Please suggest me a resolution if any one have confronted this kind of issue.
Thilina Munasinghe



Attachment(s):
logs.tar.gz
4 comments
Comment actions Permalink

Hi Thilina,

According to your log files, Upsource was started today at [2015-02-18 12:14:42] local time and then started indexing and importing commits. Indexing order is from most recent commits (=heads) up to the roots. So, Upsource should already show you the latest commits in you projects.

Normally, every commit is processed incrementally in 1-3 seconds (except for the first one, where all contents should be indexed). Total number of all commits in all your projects is about 23K.That being said, it will take not less than 19 hours to index all commits.

Also, log files indicate that after 4 hours of indexing (last record in the log happened in [2015-02-18 16:40:10]) there were no issues.

0
Comment actions Permalink

Thanks Artem. So I will wait for another 1 day for this. Anyway for the 2 projects which has most no. of commits ie. 11335 & 5992 doesn't have atleast a single commit indexed in Upsource.
Also none of the projects display latest commits done for nearly 4 hours.
Anyway as your suggestion I will wait for few hours as I presume all these issues are happenning untill the indexing process gets completed. :)

0
Comment actions Permalink

Still no luck. Have anyone facing issues in Indexing for the projects which have 1000's of SVN commits?

0
Comment actions Permalink

Hi Thilina,

Sorry for the delayed response.

Currently we are in the process of enhancing Upsource analyzer, so new optimized one will be in ncluded in the nearest release, approx in 2 months. It should fix your issue.

Sorry for that inconvenience.

0

Please sign in to leave a comment.