upsource-analyzer errors

I keep getting this in the analyzer debug.log

Resolving deltas:         92%
Resolving deltas:         93%
 at jetbrains.buildServer.buildTriggers.vcs.git.CommandLineUtil.getCommandLineError(CommandLineUtil.java:44)
 at jetbrains.buildServer.buildTriggers.vcs.git.FetchCommandImpl.fetchInSeparateProcess(FetchCommandImpl.java:162)


Any idea what the problem is?

Best Regards
Ian

14 comments

Hi Ian,

How long did it take to load your project? Also could you please clarify the repository size of your project?

Thanks in advance.

0

It takes about a minute to get this far. Then it retries again a little bit later.

The repo is about 1GB in size.


I just noticed this
[2015-01-07 11:13:38,666] WARN          VcsService-3 pl.graph.worker.VcsFetchSource - Failed to fetch repository: reponame. 'git fetch' command failed.
stderr: java.lang.OutOfMemoryError: Java heap space



I had already tried to increase heap space for upsource-analyzer as I had heap memory issues earlier in the process where it didn't even get as far as this. I set -Xmx4000m in upsource-analyzer jvm options.

Should I increase it some more?


0

Ian,

4 Gb should be pretty enough to handle the repository of your size.

Could you please clarify how did you increase heap space for upsource-analyzer?

Anyway here is a quick detailed instructions on how it should be done:

-          open <upsource>/conf/upsource-analyzer
-          create file upsource-analyzer.jvmoptions
-          write to the file –Xmx4000m

-          Restart Upsource

If the steps were done correctly please zip and post "logs" folder from the Upsource home directory.

Thanks in advance.

0

That is how I changed the heap space.

I will post the logs. Can I send them to you directly as I'm not sure if they contain sensitive information or not?

0

Any news?

Because I have the exactly same problem with the following git repository using Upsource Build 1.0.12566.

$ git count-objects -vH

count: 0

size: 0 bytes

in-pack: 116608

packs: 1

size-pack: 859.81 MiB

prune-packable: 0

garbage: 0

size-garbage: 0 bytes

$ du -sh .

1.1G .

And I set -Xmx14336m.

Just strange thing in upsource-analyzer-stderr.log I can see the following warn:


[Upsource Analyzer Error] [2015-02-18 16:15:13,157] WARN          VcsService-3 ggers.vcs.git.FetchCommandImpl - There is not enough memory for git fetch, teamcity.git.fetch.process.max.memory=1024M, try to increase it.

But I don't know where I can set this properties. I tried inside upsource.user.properties and internal/teamcity.properties but without success.

PS: find a part of upsource-analyzer-stderr.log where error spawning https://gist.github.com/kakawait/e2b75180a1a5698f8895

0

I added

 
-Dteamcity.git.fetch.process.max.memory=2G
  
to upsource-analyzer.jvmoptions
0

Thibaud,

That's correct. Use upsource-analyzer.jvmoptions file that is located under this directory <upsource>/conf/upsource-analyzer to change this setting.

Also after adding the line -Dteamcity.git.fetch.process.max.memory=2G please restart Upsource.

0

Yeah thanks It's work like a charm :) No I got another error but I no more part of OOM.

0

The following: https://gist.github.com/kakawait/40494af623f7f3bd88c9

But I currently reinstall from scratch because I tuned many thing to handle my previous memory problem. May It will fix this problem.

0

Not even after full refresh installation and just tuning the following options

conf/upsource-analyzer/upsource-analyzer.jvmoptions


-XX:MaxPermSize=4096m

-Dteamcity.git.fetch.process.max.memory=2G

I have the error.

ps: maven is not installed on the server hosting upsource. It could be the problem?

0

Well, could you please zip and post or send to upsource-support@jetbrains.com all entire contents of 2 folders located under Upsource home directory - logs and conf?

0

Done I hope it will help you. Tomorrow I will retry but I will install maven on server.

0

Please sign in to leave a comment.