VCS not connecting after 3.4 upgrade

Hi,

We have been previously running Upsource 2.5.4995 on Windows Server 2012 connected to an Atlassian cloud hosted Bitbucket account for the VCS. It has all been running fine for a while now.

Today we attempted to upgrade to the latest Upsource 3.04389. Upon following the online documentation to backup and restore the current Upscource, the upgrade appears to have processed successfully. However, under Administration in the Upsource web frontend, we now receive the following error:

Last VCS check: -

13:47:23: Check for VCS changes completed with errors. jetbrains.vcs.server.api.VcsServiceException: Failed to construct commits graph for methodology{mappings: 1, mounts: 0}. Failed to construct graph for methodology:methodology. Failed to collect commits graph for methodology:methodology. jetbrains.buildServer.vcs.VcsException: bitbucket.org failed to respond
13:47:23: Project methodology init failed due to unrecoverable VCS problem: Failed to import commits graph

We did try changing the VCS authentication method from password to SSH Keys (which are known to authenticate successfully to Bitbucket with other onsite systems here), however we still receive the same error.

Can anyone assist please?

The zipped logs folder for the upgraded v3.04389 that is failing can be accessed here:

https://www.dropbox.com/s/10zl421eg322m4b/logs.zip?dl=0

I can also provide the logs for working v2.5.4995 upon request if required.

1 comment
Comment actions Permalink

Ok so we managed to resolve this one by the following steps:

  • In v2.5.4995 changing the Bitbucket VCS auth to using SSH Keys (rather than HTTPS)
  • Let it perform a sync to confirm those SSH keys worked
  • Do a backup, then shutdown and rename folder as per documentation
  • Download and install the latest v3.0.4396 (which came out shortly after the v3.04389 we were attempting to upgrade to) as it includes fixes for Bitbucket SSH authentication
  • Restore v2.5.4995 backup
  • Allow Upsource to index and sync VCS

 

Cheers

0

Please sign in to leave a comment.