Issues processing the repository when adding the

Hi all,

 

So I setup a fresh install of the latest Upsource on an amazon m4.xlarge instance running Windows Server 2012 with an Apache proxy infront. Setup went like expected but now Im running into some issues with adding our projects. Our projects are hosted on Visual Studio Team Services in git repo`s which we access through SSH.

When I add a new project testing the VCS connection goes ok. But then it starts processing the repos and after around an hour I get the following error message:

The Upsource Analyser shows a similar message in the error log:

[2016-09-08 12:44:54,187] ================================================================ (start)
[2016-09-08 12:44:55,050] [Upsource Analyzer Error] log4j:WARN No such property [maxBackupIndex] in org.apache.log4j.FileAppender.
[2016-09-08 12:44:55,050] [Upsource Analyzer Error] log4j:WARN No such property [maxBackupIndex] in org.apache.log4j.FileAppender.
[2016-09-08 12:45:05,642] [Upsource Analyzer Error] [2016-09-08 12:45:05,640] WARN APP-WRAPPER] Proxy 1 datastax.driver.core.NettyUtil - Found Netty's native epoll transport, but not running on linux-based operating system. Using NIO instead.
[2016-09-08 13:04:20,876] [Upsource Analyzer Error] [2016-09-08 13:04:20,870] WARN yzer:INDEX_CLUSTER-2 barcodescanner urce.backend.cli.ImportSources - *** JDK sources not found at ..\..\internal\java\windows-amd64\jre\lib\..\..\src.zip
[2016-09-08 13:36:08,693] [Upsource Analyzer Error] [2016-09-08 13:36:08,683] WARN VcsService-5 my-project pl.graph.worker.VcsFetchSource - Failed to fetch repository: my-project:my-project. ssh://adress-to-my-repo.....: session is down
[2016-09-08 13:36:08,693] [Upsource Analyzer Error] jetbrains.buildServer.vcs.VcsException: ssh://adress-to-my-repo.....: session is down
[2016-09-08 13:36:08,693] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.GitCollectChangesPolicy.fetchAllRefs(GitCollectChangesPolicy.java:137)
[2016-09-08 13:36:08,693] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.GitFetchService.fetchRepositoryImpl(GitFetchService.java:55)
[2016-09-08 13:36:08,693] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.GitFetchService.fetchRepository(GitFetchService.java:44)
[2016-09-08 13:36:08,694] [Upsource Analyzer Error] at jetbrains.vcs.api.services.impl.FetchServiceProvider$1.fetchRepository(FetchServiceProvider.java:33)
[2016-09-08 13:36:08,694] [Upsource Analyzer Error] at jetbrains.vcs.server.core.impl.graph.worker.VcsFetchSource.fetch(VcsFetchSource.java:37)
[2016-09-08 13:36:08,694] [Upsource Analyzer Error] at jetbrains.vcs.server.core.impl.graph.global.CompositeGraphFactory$1.buildGraph(CompositeGraphFactory.java:79)
[2016-09-08 13:36:08,694] [Upsource Analyzer Error] at jetbrains.vcs.server.core.impl.graph.global.CompositeGraphBuilder$1.forMapping(CompositeGraphBuilder.java:97)
[2016-09-08 13:36:08,694] [Upsource Analyzer Error] at jetbrains.vcs.server.core.impl.graph.global.CompositeGraphBuilder$1.forMapping(CompositeGraphBuilder.java:82)
[2016-09-08 13:36:08,694] [Upsource Analyzer Error] at jetbrains.vcs.server.core.impl.threading.TrueParallelExecutionImpl$2.call(TrueParallelExecutionImpl.java:84)
[2016-09-08 13:36:08,694] [Upsource Analyzer Error] at __.project_my-project.__(JavaGeneratorTemplate.java:40)
[2016-09-08 13:36:08,694] [Upsource Analyzer Error] at org.jonnyzzz.stack.NamedStackFrame.frame(NamedStackFrame.java:43)
[2016-09-08 13:36:08,695] [Upsource Analyzer Error] at com.jetbrains.upsource.backend.cli.vcs.service.VcsServiceConnections$2.lambda$wrapMappingTask$4(VcsServiceConnections.java:99)
[2016-09-08 13:36:08,695] [Upsource Analyzer Error] at java.util.concurrent.FutureTask.run(FutureTask.java:266)
[2016-09-08 13:36:08,695] [Upsource Analyzer Error] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
[2016-09-08 13:36:08,695] [Upsource Analyzer Error] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
[2016-09-08 13:36:08,695] [Upsource Analyzer Error] at jetbrains.vcs.server.core.impl.threading.TrueParallelExecutionImpl$1$1.run(TrueParallelExecutionImpl.java:51)
[2016-09-08 13:36:08,695] [Upsource Analyzer Error] at java.lang.Thread.run(Thread.java:745)
[2016-09-08 13:36:08,695] [Upsource Analyzer Error] Caused by: org.eclipse.jgit.errors.TransportException: ssh://adress-to-my-repo.....: session is down
[2016-09-08 13:36:08,695] [Upsource Analyzer Error] at org.eclipse.jgit.transport.JschSession$JschProcess.<init>(JschSession.java:157)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at org.eclipse.jgit.transport.JschSession$JschProcess.<init>(JschSession.java:118)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at org.eclipse.jgit.transport.JschSession.exec(JschSession.java:91)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at org.eclipse.jgit.transport.TransportGitSsh$SshFetchConnection.<init>(TransportGitSsh.java:262)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at org.eclipse.jgit.transport.TransportGitSsh.openFetch(TransportGitSsh.java:161)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at org.eclipse.jgit.transport.FetchProcess.executeImp(FetchProcess.java:136)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at org.eclipse.jgit.transport.FetchProcess.execute(FetchProcess.java:122)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at org.eclipse.jgit.transport.Transport.fetch(Transport.java:1138)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.GitServerUtil.fetch(GitServerUtil.java:447)
[2016-09-08 13:36:08,696] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.FetchCommandImpl.fetchInSameProcess(FetchCommandImpl.java:256)
[2016-09-08 13:36:08,697] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.FetchCommandImpl.fetch(FetchCommandImpl.java:83)
[2016-09-08 13:36:08,697] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.CommitLoaderImpl.fetch(CommitLoaderImpl.java:103)
[2016-09-08 13:36:08,697] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.GitCollectChangesPolicy$FetchAllRefs.fetchTrackedRefs(GitCollectChangesPolicy.java:258)
[2016-09-08 13:36:08,697] [Upsource Analyzer Error] at jetbrains.buildServer.buildTriggers.vcs.git.GitCollectChangesPolicy.fetchAllRefs(GitCollectChangesPolicy.java:134)
[2016-09-08 13:36:08,697] [Upsource Analyzer Error] ... 16 more
[2016-09-08 13:36:08,697] [Upsource Analyzer Error] Caused by: com.jcraft.jsch.JSchException: session is down
[2016-09-08 13:36:08,698] [Upsource Analyzer Error] at com.jcraft.jsch.Channel.sendChannelOpen(Channel.java:762)
[2016-09-08 13:36:08,698] [Upsource Analyzer Error] at com.jcraft.jsch.Channel.connect(Channel.java:151)
[2016-09-08 13:36:08,698] [Upsource Analyzer Error] at org.eclipse.jgit.transport.JschSession$JschProcess.<init>(JschSession.java:150)
[2016-09-08 13:36:08,698] [Upsource Analyzer Error] ... 29 more
[2016-09-08 13:53:05,123] [Upsource Analyzer Error] [2016-09-08 13:53:05,116] WARN jects-indexer-sync-1 toring.MultiProjectMonitorImpl - Project my-project (uuid=2) is removed. Terminating analyzers...
[2016-09-08 13:53:05,123] [Upsource Analyzer Error] [2016-09-08 13:53:05,116] WARN jects-indexer-sync-1 ckend.cli.multi.ProjectContext - Dispose of ProjectContext{my-project, uuid: 2} is started

I can clone the repo on the same machine just fine with the same key and TeamCity on the same machine has no issue with as well. Anybody any idear what is going on here?

Thanks

Luuk

 

 

7 comments

Hi Luuk,

Have you installed Upsource as a Windows service?

0

Yes its running as a windows service under an account with admin rights. ALso I just tried it using https and the vsts alternate credentials and that works fine. But I would really like to use ssh for security reasons.

0

Ok, thank you for the clarification. Please try to add your .ssh to the home directory of a user, Upsource service is running under.

0

The keys in question was generated under said account and there already there.

0

Could you please share your repository link structure?

Does it look like this - ssh://user@host/path/to/repository or this one - ssh://git@host/path/to/repository?

0

It look like the first one: ssh://user@host/path/to/repository

0

Please sign in to leave a comment.