Installation Issue

I'm installing up source, I get to the screen that says: 

"Please be patient and do not close this page until the setup is complete", this is the url: http://localhost:8082/wait?url=http:%2F%2F127.0.0.1:8082%2Fbundle%2Fstarting%2F 

This page just hangs. I opened chrome developer tools and I see a bunch of errors.

See image: 

Upon taking a look at the upsource logs I see the following: 

 

[2016-08-30 20:37:29,149] upsource-psi: [Upsource PSI Service Error] log4j:WARN No such property [maxBackupIndex] in org.apache.log4j.FileAppender.
[2016-08-30 20:37:29,151] upsource-psi: [Upsource PSI Service Error] log4j:WARN No such property [maxBackupIndex] in org.apache.log4j.FileAppender.
[2016-08-30 20:37:29,151] upsource-psi: [Upsource PSI Service Error] [2016-08-30 20:37:18,464] ERROR APP-WRAPPER] Proxy 1 net.sf.ehcache.Cache - Unable to set localhost. This prevents creation of a GUID. Cause was: unallocated.barefruit.co.uk: unallocated.barefruit.co.uk: unknown error
[2016-08-30 20:37:29,155] upsource-psi: [Upsource PSI Service Error] java.net.UnknownHostException: unallocated.barefruit.co.uk: unallocated.barefruit.co.uk: unknown error
[2016-08-30 20:37:29,155] upsource-psi: [Upsource PSI Service Error] at java.net.InetAddress.getLocalHost(InetAddress.java:1505)
[2016-08-30 20:37:29,155] upsource-psi: [Upsource PSI Service Error] at net.sf.ehcache.Cache.<clinit>(Cache.java:217)
[2016-08-30 20:37:29,155] upsource-psi: [Upsource PSI Service Error] at net.sf.ehcache.config.ConfigurationHelper.createCache(ConfigurationHelper.java:303)
[2016-08-30 20:37:29,155] upsource-psi: [Upsource PSI Service Error] at net.sf.ehcache.config.ConfigurationHelper.createDefaultCache(ConfigurationHelper.java:219)
[2016-08-30 20:37:29,155] upsource-psi: [Upsource PSI Service Error] at net.sf.ehcache.CacheManager.configure(CacheManager.java:649)
[2016-08-30 20:37:29,155] upsource-psi: [Upsource PSI Service Error] at net.sf.ehcache.CacheManager.doInit(CacheManager.java:408)
[2016-08-30 20:37:29,156] upsource-psi: [Upsource PSI Service Error] at net.sf.ehcache.CacheManager.init(CacheManager.java:358)
[2016-08-30 20:37:29,156] upsource-psi: [Upsource PSI Service Error] at net.sf.ehcache.CacheManager.<init>(CacheManager.java:340)
[2016-08-30 20:37:29,156] upsource-psi: [Upsource PSI Service Error] at com.jetbrains.upsource.backend.server.UpsourceCacheManager.<init>(UpsourceCacheManager.java:37)
[2016-08-30 20:37:29,156] upsource-psi: [Upsource PSI Service Error] at com.jetbrains.upsource.backend.server.facade.UpsourceApplicationEnvironment.<init>(UpsourceApplicationEnvironment.java:126)
[2016-08-30 20:37:29,156] upsource-psi: [Upsource PSI Service Error] at com.jetbrains.upsource.backend.cli.UpsourceApplicationEnvironmentDaemonBase.startDaemon(UpsourceApplicationEnvironmentDaemonBase.java:13)
[2016-08-30 20:37:29,157] upsource-psi: [Upsource PSI Service Error] at com.jetbrains.upsource.backend.cli.UpsourceDaemonBase.start(UpsourceDaemonBase.java:144)
[2016-08-30 20:37:29,157] upsource-psi: [Upsource PSI Service Error] at com.jetbrains.upsource.backend.cli.UpsourceDaemonBase.start(UpsourceDaemonBase.java:234)
[2016-08-30 20:37:29,157] upsource-psi: [Upsource PSI Service Error] at com.jetbrains.launcher.AppProxy$6$1.call(AppProxy.java:99)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at com.jetbrains.launcher.AppProxy$6$1.call(AppProxy.java:97)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at java.util.concurrent.FutureTask.run(FutureTask.java:266)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at java.lang.Thread.run(Thread.java:745)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] Caused by: java.net.UnknownHostException: unallocated.barefruit.co.uk: unknown error
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:928)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1323)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] at java.net.InetAddress.getLocalHost(InetAddress.java:1500)
[2016-08-30 20:37:29,158] upsource-psi: [Upsource PSI Service Error] ... 18 more

 

What might be going on here? Thoughts on how to fix? 

11 comments
Comment actions Permalink

Hello, Donn!

According to your config, service was started on port 8080 and couldn't be opened by http://localhost:8082.

Perhaps, another instance was started on 8082 at the same time. 
Make sure that nobody listen to 8082.

then you might reconfigure your Upsource instance by the following commands:

> bin/upsource stop
> bin/upsource configure --base-url=http://127.0.0.1:8082 --listen-port=8082
> bin/upsource start

Now service should be be available by http://127.0.0.1:8082
If Upsource is available by that local address, you might try to reconfigure that to be available by hostname:
> bin/upsource stop
> bin/upsource configure --base-url=http://<hostname>:8082 --listen-port=8082
> bin/upsource start

If service won't be accessible by the URL containing hostname it means hostname is not associated with any net interface of server. in that case please check that hostname -s/ hostname -f are associated with 127.0.0.1 localhost in  /etc/hosts

 

If that is the case and you still experiance the problem, please file an issue to Upsource project https://youtrack.jetbrains.com attaching the following:
- output of ifconfig,
- output of hostname -f 
- output of hostname -s 
- content of logs directory from installation home
- content of conf directory from installation home

Sincerely,

Alexey Barsov

1
Comment actions Permalink

Hello, Donn!

It look like a hostname is not properly configured on server (what is the output of hostname -f/hostname -s?).

Defining hostname should solve the issue.


0
Comment actions Permalink

Hello Alexey, I ran this command and I received a proper host name for both commands. 

vagrant-ubuntu-wily-64.foo.bar.com 

The domain changed of course, for privacy.

As you can see, I'm also setting this up in a vagrant instance, as that is how my client has their system configured. Would that be causing this problem possibly? 


Donn

0
Comment actions Permalink

Hello, Donn!

Is seems hostname is not registered in /etc/hosts, could you please check that?

In that case adding the line (association of local host and hostname) might resolve the issue:

127.0.0.1 localhost <hostname_here>

Sincerely,

Alexey Barsov

 

 

0
Comment actions Permalink

Hey Alexey

I've added both hostnames to /etc/hosts. Here's what it looks like: 

 

127.0.0.1 localhost vagrant-ubuntu-wily-64 vagrant-ubuntu-wily-64.ads.aexp.com

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

 

Upon starting upsource again, I get the following client side errors (see image). Thoughts? 



0
Comment actions Permalink

Hello, Donn!

I guess removing of <upsource.home>conf/internal directory would help

(it seems that previously calculated incorrect base URL was cached and has not been updated with actual value)

Alternatively, you might simply unpack an upsource distributive again and start it from scratch.

 

Sincerely,

Alexey

0
Comment actions Permalink

Hello Alexey, 

I've started withe a clean machine and I'm still running into the issue. On the initial setup screen we its asks for the URL and port. I enter 8082 for the port and I get a popup that says the location cannot be reached. If I change it back to 8080, then it works. However, it cannot be 8080 because 8080 is taken by another service. 

Thoughts? 

0
Comment actions Permalink

have you opened wizard by http://localhost:8080/?  

If yes, 8082 should be set both in base-url and in listen-port input fields (base-url should correlate with listen address in case base-url is not an address of some proxy)

could you please attach content of conf/internal/bundle.properties of your instance and logs if you would still experience an issue?

 

 

 

0
Comment actions Permalink

No, I'm opening the wizard on http://localhost:8082

Alexey, here is the contents of the bundle.properties: 

 

#Bundle Settings. Don't update this file manually, use command line API instead: /home/vagrant/upsource-3.0.4396/bin/upsource configure --propertyName=newValue
#Fri Sep 09 16:42:49 UTC 2016
base-url=http\://127.0.0.1\:8080/
installation-uuid=ee692564-326a-4557-8f76-b480dd997db7
port-base.bundle-hub-configurator=10000
additional-keystore-password=capIuha39Y
listen-port=8080
listen-address=0.0.0.0
port-base.cassandra=10050
logs-dir=logs
temp-dir=temp
port-base.upsource-psi=10020
port-base.upsource-frontend=10010
statistics-upload=true
port-base.upsource-monitoring=10060
port-base.upsource-analyzer=10030
root-user=admin
data-dir=data
backups-dir=backups
allow-anonymous-access=true
locale=en-US
disable.hub=false
port-base.upsource-cluster-init=10040

0
Comment actions Permalink

Alexey, 

 

I was able to set up Upsource finally. It seems running these commands is what needed to happen. Thank you for this. 

0
Comment actions Permalink

I have the same problem.

 

I uploaded all 4 packages like this (Linux):

domain.com/Hub

domain.com/YouTrack

domain.com/TeamCity

domain.com/Upsource

 

Then I ran "./hub.sh start" and the result is exactly the same as the first screenshot of OP.

 

I set the base URL in Wizard at http://domain.com:8082/Hub  (I tried setting the root as well, but no result)

 

I tried testing the whole process in the exact same situation on localhost, and the set up was completed as expected with no error and I could use it. Not sure why I can't make it work on my server though.

 

Any help is appreciated.

0

Please sign in to leave a comment.