Upsource code intelligence not finding maven dependencies

Hello,

 

I have an intellij project in upsource with mutiple maven modules under the root directory.

When I turn on code intelligence in upsource, it parses those files but does not seem to be resolving any of the maven dependencies, instead marking all the imports and classes that come from dependencies as errors.

Here is the current code intelligence config:

 

My project has the .idea directory checked in with the following structure:

I also tried setting up the code intelligence as a maven project and just pointing it to one of the maven modules, and that also seemed not to work.

 

Can you offer any advice on how I might have misconfigured things?

5 comments

Do you have a common pom.xml file? And if you do, where is it located?

0

We do not have a common pom.xml file. Each Java/Kotlin sub project has its own independent pom.xml.

0

Hi any more thoughts on this issue?

 

Do you think changing our project to have a root pom.xml is necessary to make it work?

0

Hey! Sorry for the delay.

Yes, a root pom.xml is required for Upsource to recognize all your modules. 

0

Hi I haven't followed up on this in a while, but this has continued to be an issue for us. We changed to project to have a root pom months ago, and have tried configuring it as both a maven and intellij project, but it never finds opur external libraries.

 

This is very frustrating since this is one of the main value adds we are supposed to get from upsource. 

 

0

Please sign in to leave a comment.