Upsource svr behind F5

My Upsource server is behind an F5 which is terminating the SSL and receiving connections on port 443.  It sends the traffic to my upsource server on port 8080.  From the internet we use https://upsource.<mydomain>.com where the server and base_url are servername.<mydomain>.com:8080.  When I connect to https://upsource.<mydomain>.com I get an upsource page but then get redirected to http://servername.<mydomain>.com:8080 which is an invalid address from the internet.  I have configured upsource to accept https://upsource.<mydomain>.com as a valid URL.  Is there a way to tell upsource to use the same URL as it was contacted on when it does the redirect?

I think I have a workaround, and that would be configuring the server's base_url to be the external address.  In that case, the redirect would work but then accessing the server from my internal networks would not work as the external DNS name would resolve to an address that exists in my FW.

upsource.<mydomain>.com = 23.148.x.x external address

FW receives traffic on port 443, does NAT on the destination to a 192.168.x.x address that is a VIP on my F5

F5 receives traffic on port 443, terminates the SSL, and sends it to the server on 8080

1 comment
Comment actions Permalink

I resolved this by configuring the server with:

./bin/upsource.sh configure --listen-port 8080 --base-url https://upsource.mydomain.com/

And configuring my F5 with the appropriate X-Forwarded rules:

https://devcentral.f5.com/s/question/0D51T00006n5Sja/how-to-enable-xforwardedhost-

0

Please sign in to leave a comment.