HELP! How to update the server TLS certificate?

I'm using Upsource 2019.1 with TLS and it worked fine until my certificate expired. I have a new one but I can't find a way to get the server to use it. I have tried shutting down the server and running 

sudo -u webadm /opt/upsource/upsource-active/bin/upsource.sh configure --listen-port=8443 --secure-mode=tls --tls-server-cert-folder=/opt/upsource/certificates/202006 --tls-server-cert-keystore-file=/opt/upsource/certificates/202006/keystore.jks --tls-server-cert-keystore-password=PASSWORD_GOES_HERE --tls-server-cert-keystore-key-alias=KEYSTORE_ALIAS_GOES_HERE --tls-server-cert-keystore-key-password=PASSWORD_GOES_HERE --tls-redirect-from-http=true --tls-redirect-from-http-listen-port=8080 --base-url https://SUBDOMAIN.MYDOMAIN.com:8443

But it still uses the old certificate; I have no idea how.

When I first setup 2019.1 it had this nice user interface to use a TLS certificate; I cannot get the configure wizard to reload.

Help!!!!!

1 comment
Comment actions Permalink

Ugh. Somehow I got it to work. I tried different variants using upsource.sh configure from https://www.jetbrains.com/help/upsource/2019.1/configuring-tls.html#

I think the only thing different I had to do was use a relative path for the keystore file:

sudo -u webadm /opt/upsource/upsource-active/bin/upsource.sh configure --listen-port=8443 --secure-mode=tls --tls-server-cert-folder=/opt/upsource/certificates/202006 --tls-server-cert-keystore-file=keystore.jks --tls-server-cert-keystore-password=PASSWORD_GOES_HERE --tls-server-cert-keystore-key-alias=KEYSTORE_ALIAS_GOES_HERE --tls-server-cert-keystore-key-password=PASSWORD_GOES_HERE --tls-redirect-from-http=true --tls-redirect-from-http-listen-port=8080 --base-url https://SUBDOMAIN.MYDOMAIN.com:8443

0

Please sign in to leave a comment.